
Microsoft Excel Tips 
 Summarized by Patrick Mount 

 
 
 
 
 
This ‘refresher guide’ contains a completely incomplete list of common tips, steps, and processes used 
when working with spreadsheets using Excel.  
 
Formatting cells: 

Note: for your editing convenience, be sure the ‘Formatting’ toolbar is fully visible.  

Begin by selecting the cell(s) that you wish to format.  Clicking and dragging can select groups of cells, 
and entire rows or columns can be selected by clicking on the row or column header(s).   To select non-
adjacent cells, select the first set of cells as described above, then hold down the Crtl key while 
selecting additional sets of cells. 

•   Used to Bold, Italicize, or Underline contents of a cell. 

•  Used to justify the contents of a cell (left, center, or right). 

•  Used to center contents of one cell over a merged selection of cells. 

•  Used to format numerical values as currency or as a percent. 

•  Used to increase or decrease the decimal places for numerical values. 

 

 

 

• Used to create various 
borders around selected 
cells or groups of cells. 

• Used to fill a cell with a 
background color. 

• Used to alter the font color 
of a cell’s contents 

 
• To adjust row height or column width, Place cursor between row or column headings, click, and 

drag to desired size. Double-click to auto-adjust to fit cell contents. 
• Select cell immediately beneath and right of cells you wish to freeze.  Window > Freeze Panes 

from the menu bar will cause those cells to display as the document is expanded. 
• Additional formatting, including text alignment can be performed using Format > Cells from the 

menu bar, and selecting the appropriate tab. 
 
Cell Comments 
Comments can be added to cells allowing for additional information or notations.  Begin by selecting 
the cell to be annotated, click on the  button, type the comment, and then click away from the 
comment box.  Once entered, the annotated cell will display a red dog-ear , and the 
comment will appear as the cursor is hovered over the cell. 
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Sorting Data 

Data may be sorted by column in either ascending or descending order, by up to three constraints.  

Consider the spreadsheet below (on the left), initially sorted in ascending order by “Last name:” We 
may wish to sort this instead by “Total Years” or by “Windsor Years”.  To do so,  

1) Select the rows data that you wish to have 
sorted (in this case, rows 3 – 11); [To select 
non-adjacent cells, hold down the Ctrl key]. 

2) Select Data > Sort from the menu bar. 
3) A window will appear allowing you to 

customize your sort.   
4) Since we have included the category titles in 

the selection, be sure the ‘My list has Header 
row’ is marked. 

5) Click on the pop-up menu and choose the 
category by which the data is to be sorted (In 
this case, Total Years, then Windsor Years). 

6) Choose either Ascending (increasing from 
smallest to largest) or Descending (largest to 
smallest). 

7) Click ‘OK,’ and the data will be sorted. 
 

The ‘Options…’ button allows the user to choose to sort by row rather than by column. 

Notice that the spreadsheet on the right is now sorted according to our instructions, and that the data 
read across the rows reads as it did in the original spreadsheet, just with the rows in a different order.   

 
Sort 1: Alphabetically by Last Name  Sort 2: Total Years, then by Windsor Years 

Important: This very useful feature has to be used carefully, however, or your data could become 
corrupted!  For example, if we selected only the data in cells C3:D11 for our sort, then the result would 
have appeared as: 

Notice that with sort 3, the data order for Last 
Name matches that of Sort 1, but the Experience 
columns match those of Sort 2, and the years of 
experience do not match properly with the names.  
In other words, the data had become corrupted!   
 
Avoid this trauma by selecting all of the related 
data in each row.  In this case, that would be 
A3:D11. 
 

 
Sort 3: Total Years, but incorrect association to Names. 
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Filtering Data 

Data can instead be filtered to display only selected criteria.   Using the preceding example, suppose 
we wanted only to see a list of individuals with more than 15 years of experience in the education: 

1) Select the entire data set to be considered  
2) From the menu bar, select Data>Filter>AutoFilter 
3) Notice that now each of our headings contains a drop-down menu of choices, populated by the 

contents of the cells beneath it, as 
well as three pre-defined options.  
In this case, we want a custom 
filter of those whose Total Years 
> Is greater than >15 (use these 
selections in each window of the 
ensuing wizard).   

4) The resulting display includes 
only those whose criterion meets 
these conditions.  This filtered data can now be sorted as described above, and formula values 
will remain intact.   

5) If desired, the data can be further filtered by another column. 
6) To un-filter the data (and thus to see it all), select Data>Filter>AutoFilter from the menu bar. 

 
Pivot Tables 

Similar to filtering, Pivot Tables allow one to quickly summarize data with an interactive data analysis 
sheet. Pivot tables consist of rows & columns (which will contain data headers), and data (values of the 
chosen data headers).  Once created, columns of data can be easily filtered or hidden.  Begin by 
selecting Data > Pivot Table…  and follow the steps of the wizard.   
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Copying, Pasting, and Dragging 
 
 Once one has formatted cells and 
entered information (values, labels, 
and/or formulas) that will be repeated, 
the drag option can save substantial 
amounts of time.  To the right is a 
review of the cursors and their functions. 
 
To simply copy and paste, select the 
source cell and Copy (Ctrl+C or ), 
and then select the designation cell and Paste (Ctrl+V or ).  Even sets of cells, or entire 
rows, column, or worksheets may be copied and pasted.   If only certain aspects of a cell (such 
as the formats, comments, or borders) are to be pasted, use the Edit > Paste Special option 
from the menu bar.   

Appearance Function 
 Tool Selector 

 
Cell Selector 

 Adjust column or row height.  Place 
cursor in between column or row 
headings. 

 Drag tool.  Select cell and place 
cursor in lower-right corner of a cell. 

 
[Note: If using more that one source cell, the designation cells’ quantity and dimension must 
exactly match that of the source cells (or be an integer multiple thereof).  If this is awkward, 
select only one destination cell, and Excel will make exactly one paste of the source cells 
beginning in that cell). 
 
Using drag tool is a wonderful way to quickly copy or auto-fill cells.  For example, type 
‘Monday’ into a cell, then drag that cell either down or right.  Doing so will populate the cells 
with the days of the week.  This is also useful for creating sequences of numbers, months, etc.     
 
Using Formulas 

• Formulas may either be created by the user (using the math operands of +, -, *, /, and 
^), or generated with the Paste Function ( ) wizard.  

 
• Formulas may involve specific numbers, or values contained within other cells. 

   
• Formulas that obtain information sets of cells refer to those cells by the upper-left-

most-cell to the lower-right most cell (i.e. A1:B6). 
 

• All formulas must begin with the equal sign (‘=’).   

Common formulas 

Purpose Example 
Adds the values from within a set of cells =SUM(B5:B12) 
Averages the values from within a set of cells =AVERAGE(B5:B12, C5:C12) 
Counts the quantity of numerical values from 

within a set of cells  
=COUNT(A1:J1) 

Counts the quantity of non-empty cells from 
within a set of cells 

=COUNTA(C1:C800) 

Counts the quantity of cells meeting a specific 
requirement from within a set of cells 

=COUNTIF(C1:C500,4.0) 
=COUNTIF(B1:B500, “>=3.5”) 
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Copying Formulas and Using Cell References 

The drag tool will quickly copy and paste formulas, adjusting cell references as necessary.  However, if 
some of those cell references are intended to be unadjusted, the referred-to cell must be locked as 
absolute by placing a dollar sign (‘$’) before the referred-to cell’s row or column (or both) address in 
the equation.   
 
Example:  Consider this spreadsheet, which displays the daily attendance at a local and fictitious water 
park.  Water park managers want to assess the total attendance and income by week and by day-of-the-
week.  To complicate matters, the admission fee is not constant from week to week:  

 
Finding the total attendance is relatively simple, and the formula used in one cell for this summary can 
be dragged across or down to the rest of the cells. 
   
So the formula used to determine the day-of-the-
week total is simply the sum of the appropriate 
column.  It can be entered in cell C8, and then be 
dragged across row 8. 

Cell Purpose Formula 
C8 Add column =SUM(C4:C7) 
D8 “ =SUM(D4:D8) 
E8 “ =SUM(E4:E8) 
F8 “ =SUM(F4:F8) 
G8 “ =SUM(G4:G8) 
H4 Add row =SUM(C4:G4) 
H5 “ =SUM(C5:G5) 
H6 “ =SUM(C6:G6) 
H7 “ =SUM(C7:G7) 
I4 Weekly Income =B4*H4 
I5 “ =B5*H5 
I6 “ =B6*H6 
I7 “ =B7*H7 

 
Similarly, determining the weekly total is a matter 
of summing the appropriate row.  Enter the 
formula in cell H4, and drag down column H.   
 
Finding the weekly income is a little more 
challenging, as we need to multiply the weekly 
total by the admission for the week.  However, 
that formula can entered into cell I4 and be 
dragged down column I without incident. 
 
Finding the day-of-the-week Income, however, is much more difficult, and when dragged across the 
row can create a mess if the referenced cells are not ‘locked.’  To obtain the proper value for all 
Mondays’ total income, we need to multiply each admission by its attendance, and add the total.  We 
may choose to create this formula for each day of the week, but it would be quicker to drag.  It will be 
necessary to lock the column reference of the admission fee, so a dollar sign is placed in front of that 
reference in the formula (notice the $ before each B): 
 

Cell Purpose Formula 
C9 Day-of-week income =C4*$B4+C5*$B5+C6*$B6+C7*$B7 
D9 “ =D4*$B4+D5*$B5+D6*$B6+D7*$B7 
E9 “ =E4*$B4+E5*$B5+E6*$B6+E7*$B7 
F9 “ =F4*$B4+F5*$B5+F6*$B6+F7*$B7 
G9 “ =G4*$B4+G5*$B5+G6*$B6+G7*$B7 
If we were to need to lock the row reference, the dollar sign would be placed in front of the number 
(example: B$4), and if we needed to lock the cell entirely, place the sign before both ($B$4).
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Creating Graphs 

Graphs (used synonymously with  ‘charts’ in Excel) provide a nice visual display of data, and 
are surprisingly easy to create using the Chart Wizard button ( ). 
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These charts show the attendance by both week and by day.  The chart types are 3-D column 
on the left, and area on the right. 

1) Highlight the data to be charted; include labels if desired (in this case cells A3:A7 and 
C3:G7 were highlighted, [Hold the Ctrl key to select non-adjacent cells]). 

2) Click the Chart Wizard button ( ), and you will be walked through a host of choices: 
a. Type of chart (use the  to get a preview of the 

results of your choices. 
b. Data Range and Series by column or by row. 
c. Chart Options . 
d. Chart location (within worksheet or in its own worksheet). 

  
Once the graph is created, any of the above can be altered.  Simply double-click to on the chart, 
then right click on that which is to be edited, and select ‘format….’ 
 
Glossary of Basic Terms: 

• Sheet- one page in a workbook; can be inserted, deleted, copied, renamed, or relocated. 

• Columns- vertical, labeled with letters across the top of a sheet; can be inserted, deleted, or 
copied. 

 
• Rows – horizontal, labeled with numbers. can be inserted, deleted, or copied. 

• Cells – boxes in which data can be entered; referred to by its column-row intersection (for 
example, C2 refers to the cell in the C column in the 2nd row).  The data in cells can be labels 
(typically words), numbers (including dates, fractions, etc.), or formulas.  

 
• Range – group of cells, usually adjacent to one another (for example, the range B4:D7 consists 

of a total of 12 cells in a 3-column by 4-row block). 
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